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Overview of CMS? 

What is a Content Management System (CMS) 

A content management system (CMS) is system designed to help manage and access various types of content. Organized in a clear and intuitive 
structure, a CMS can ensure that the most accurate and up-to-date information is easily accessible and regularly reviewed and updated. The 
content management system we use to store eCalendar information is called Webtop (Documentum).  
 
eCalendar content stored in Webtop goes through the following life cycle: 
 

Create Edit Review Publish Archive 

 
Webtop also manages the properties of each file; controls access to content based on user permissions; and enforces business rules and 
regulatory requirements. Webtop can be accessed online at https://cms.mcgill.ca/webtop. 

https://cms.mcgill.ca/webtop
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Browser Requirement 
Webtop requires Internet Explorer version 7-11 for full functionality. 
 
XMAX, the editing software associated to Webtop, requires Internet Explorer version 7-11 for full functionality; it does not work in any other 
browser. 
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Installation Requirement 
The following installation steps are for Internet Explorer 7-11 and are required before using Webtop or XML document in XMAX: 

Add the Webtop URL to your browser's trusted sites. 

1. From the IE menu, click Tools > Internet Options.  
2. pGo to the Security tab and click Trusted sites from the box at the top labeled Select a zone to view...  
3. Click the Sites button.  
4. Type in the URL https://cms.mcgill.ca/ and click Add.  
5. Click Close.  
6. Click OK.  

Set the security settings to Low for trusted sites, to allow the ActiveX control to run.  

1. From the IE menu, click Tools > Internet Options.  
2. Go to the Security tab and click Trusted sites from the box at the top labeled Select a zone to view...  
3. Click Custom level... at the bottom of the window.  
4. At the bottom of the dialog, in the dropdown labeled Reset to: select Low (This is the Default level for IE 6).  
5. Click OK on the Security Settings dialog.  
6. Click OK again on the Internet Options dialog.  

If Popup-Blocker is turned on, add the Webtop URL to your browser's list of pop-up exceptions: 

1. From the IE menu, click Tools > Internet Options.  
2. Go to the Privacy tab.   
3. If the Turn on Pop-up Blocker check box is not checked you don't need to continue; just click Cancel. Otherwise, click Settings in the 

Pop-up Blocker area at the bottom of the dialog.   
4. Type in the URL https://cms.mcgill.ca/ and click Add.  
5. Make sure the Filter level at the bottom of the dialog is set to "Low: Allow pop-ups from secure sites".   
6. Click Close.  
7. Click OK.  

 
Note: Once you have made these changes, close your browser and reopen it in order for the new security settings to take effect. 

Users running Internet Explorer 11 also need to turn on Internet Explorer’s “Enterprise Mode” setting: 

1. Refer to http://kb.mcgill.ca/#tab:homeTab:crumb:8:artId:7326:src:article for instructions on how to turn on Enterprise Mode. 

http://kb.mcgill.ca/#tab:homeTab:crumb:8:artId:7326:src:article


 

 9 27 September 2017 

  

Understanding the eCalendar workflow 

During review periods, eCalendar topics go through a workflow to be reviewed sequentially by each reviewer/content specialist. When you finish 

reviewing a topic in the workflow, it is automatically sent to the next person in the workflow. 

eCalendar workflow procedures: 

1. The eCalendar team will arrange a kick-off meeting to discuss the coming review cycle. 

2. Following this meeting, a spreadsheet will be sent to all faculties/schools involved (via eCalendar faculty coordinators) containing a list of 

all eCalendar sections (a.k.a. topics), and reviewers for each section. Coordinators will be asked to confirm that all reviewers for each 

section have not changed, and confirm which topics should be sent out for review in the workflow. 

3. The Managing Editor will initiate the workflow by sending out an email in Outlook to start the review process. The general workflow 

passes through these roles: 

 

   Editor       Approver             Coordinator       Coordinator 2 Copy Editor    Technical Verification 

 

Each topic has been assigned reviewers based on subject expertise at the unit and faculty level: an editor, approver, coordinator, and 

coordinator 2. A notification is sent to each person in the workflow, both in Outlook and Webtop (https://cms.mcgill.ca/webtop), to 

notify them when it is time to take action on a given topic. The task can be accessed through their Webtop inbox. Each task contains a 

topic that needs to be reviewed or edited. Topics are pieces of eCalendar content in XML format. 

4. Editor: after clicking on the link from the email, an Editor logs into Webtop, views their Inbox, selects a topic to review, verifies the 
topic’s content and modifies as needed, saves the changes, and forwards the topic on to the Approver by clicking “Finish”. 

5. Approver: will review the topic content and changes made by the Editor and further modify content if needed, before forwarding it on 

to the Coordinator by clicking “Forward”. The Approver can also add comments to the topic and reject it back to the editor for further 

changes. The editor will make the changes and send the topic back to the Approver for another review. 

6. Coordinators: will verify that all changes made are accurate and appropriate before signing off on the topic. He/she can also choose to 

contact the Editor or Approver directly for further clarifications, and make further changes to the content if needed. The Coordinators 

can leave comments and reject the topic back to the Approver or Editor if necessary; the Coordinator will then see the document again 

for another review and sign-off before sending it on to the Copy Editor in Enrolment Services. 

7. Copy Editor: will verify that all content is free of typos, grammatically correct, and contains consistent styling. If there are major 
inconsistencies or the information is unclear, inconsistent, or inappropriate, the Copy Editor will contact the appropriate performer 
directly to discuss the change or reject the topic back to them. 

8. Technical Verification: will verify all information for consistency and ensure the technical requirements for publication are met. 

9. Translator (optional): will insert translated text into French topics. 

 
Roles are described further under: Getting Started for Individual Roles. 

https://cms.mcgill.ca/webtop
https://cms.mcgill.ca/webtop/
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Webtop – Content Management System 

What is Webtop? 

Webtop is the web-based interface you will use to access content stored in the Documentum content management system.  
 
The Webtop interface is a powerful tool which allows you to: 

• Create files and folders   
• View the contents of files and folders   
• Edit files   
• View and change the properties of files  
• Review files in workflows with up to 6 reviewers 
• …and much more  

 
However, for the eCalendar, you will only be using the features that have been defined based on your role (Editor, Approver, or Coordinator). 

Browser Requirements 

Webtop requires Internet Explorer versions 7–11 for full functionality. Limited functionality is available using Mozilla Firefox 2.0. 

Log into Webtop 

To access contents of the CMS, you need to log into Webtop. Enter the URL for the system in your browser address bar: 

https://cms.mcgill.ca/webtop and go to the site. 
 

1. Enter your McGill Username.  
2. Enter your McGill Password.  
3. The Repository should be set to “CMS_ADMIN”.  
4. For security reasons, do NOT check the Remember my credentials checkbox.  
5. Click Login to proceed. 

To access Webtop quickly in the future: 

Save the Webtop URL as a Favorite in your browser. Click Favorites > Add to Favorites in the Internet Explorer toolbar. Or, create a shortcut to 

that URL on your desktop: 

1. Right-click on your Windows desktop and select New > Shortcut.  
2. Paste in the URL:  https://cms.mcgill.ca/webtop and click Next. 
3. Type in “McGill Webtop” in the Name field and click Finish. 

Exploring Webtop Interface 

The Webtop interface looks very similar to Windows Explorer: 
 
 
 
 
 
 
 
 

https://cms.mcgill.ca/webtop
https://cms.mcgill.ca/webtop
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Webtop interface: Navigation tree in left-hand pane, Contents on the right. 

Tree pane 

In the left-hand pane you see a tree-view structure of files. There are different types of functions: 

 Inbox – This contains tasks and notifications. Files that are sent to you for reviewing during eCalendar review periods. 

 Saved Searches – This contains pre-defined searches that you have saved 

 Subscriptions – You can subscribe a file to someone or yourself for easier access to the file. This file will appear in the Subscriptions 
function. When you access this file from the Subscriptions function, the file is retrieved from its original repository location. 

 My Files – This is a list of your recent files. Note that this will not be used for the eCalendar. 

 Categories – Categories are not being used at McGill. 

 My Home Cabinet – This is similar to My Documents in Windows. It allows you to store links (shortcuts) to the files and folders from 

other cabinets for easy access. 

 Cabinets – These are all the cabinets in the current repository that you have permission to view. Note that you may not have permission 

to edit all of the files within these cabinets. Click the plus sign next to a folder to expand the view, or the minus sign to collapse the view. 

All eCalendar content is stored in the “eCalendars” Cabinet. 

 Content Pane – Depending on what you choose from the Tree pane, you will see its folder and/or files in the content pane. 

 Menu bar – The menu bar above the content pane contains context-sensitive actions that you can perform depending on what is 

selected. 

 Navigation path – The Navigation path is located just below the menu bar. It is similar to “breadcrumbs” that you may see on web 

pages, it shows the folder hierarchy of the current contents. You can click on folders within the path to navigate back up the hierarchy. 

 Viewing options – You can view your files and folders in details or thumbnail view: 

 

 

1. This allows you to choose if you want to view your files and folders in details or thumbnail view. 
2. This only appears if there is a large number of items for viewing. 
3. This allows you to choose the number of items to display on a page.  
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 Files/folders listing – When you select a folder from the Tree pane, the list of files within that folder appears on the content pane. Here 
you can view the default setting details of each file, such as: 

o Format – type or application associated with the file (XML, DITA map, Word, HTML, JPEG, etc.) 
o Name – of the file or folder 
o Modified – date the file or folder was last updated 
o Category – special project-specific designation for certain files 
o Version – the current version number for the file 

You can customize the default attributes that appear in this view by clicking the icon that looks like this: 
In the Preferences: Display Settings: Columns for Cabinets window, use the left and right arrow buttons to add or remove attributes; use 

the up and down arrow buttons to choose the order attributes appear within the content pane. 

 

 

 

 

 

Changes made using this button only affect the folder you are currently 

viewing. To change the default column settings for all cabinets, click Tools > 

Preferences from the Menu bar, click the Columns tab, and follow the same 

procedure. 

 

 

Logging Out 

When you are finished working in the CMS or leaving your workstation unattended, click the Logout button in the upper right corner of the 

screen. 

 

 

 

 

This ensures that your session is closed properly and your files and folders remain secure. The CMS keeps track of all file modifications, and you 

are responsible for any changes made to files in your name. 
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Managing Files 
Documentum, like other content management systems, uses a system of locking files while being edited, so only one user at a time can edit a 

file. This is also referred to as Checking Out the file. When you have finished making changes to the file, be sure to Check In the file so that 

others can access it. 

 

In the content pane, files that are checked out by you have a key icon  next to them, and files checked out by others have a lock icon . 

 

Note: When you check out a file, the system automatically creates a temporary copy of the file in your local computer. Simply clicking Save only 

updates this temporary copy; to properly save changes to the file in the CMS, you need to both Save and Check In the file. 

 

If you need to access the temporary copy for whatever reasons, it is usually stored in the following path: 

C:\\Documents and Settings\your _username\Documentum\Checkout OR 

C:\\Users\your_username\Documentum\Checkout 

Procedure to manage your files 

To access and update your files: 
1. Right-click > Edit your file to modify it  
2. File > Save and File > Check in your file when you are finished editing to save changes 

Other ways to manage files: 
• Cancel check out: cancels the lock on the selected file (Note: you will lose any changes to the file.) 

Editing a file 

From the content pane, right-click on the filename and select Edit. The file will be automatically checked out by you (locked for others) and it will 
open for editing in same window. 

 
 
 
 
 
 
 

After you click on Edit, you will see a key icon   and other users will see a lock icon   next to the file. 
This means: 

 Others cannot make changes to it 

 Others can only view the last version(s) 

 The Edit function is disabled for other users 

 Others cannot see new changes being made 

Note: If you work with Webtop from multiple computers, be sure to Check In any files before moving to the other computer; otherwise, they will 

be locked and inaccessible from any computer besides the one from which they were originally checked out. 
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Checking In a file 
 
When you are finished editing a file, you need to Check In the file to save it in Webtop and others can access it. The procedure of checking in the 

file also saves it with a new version number, so that there is a record of the changes made since the last time it was edited. You can tell if your 

file is still checked out by looking for the key icon  beside the file name: 

 

1. From the content pane, right-click on the file and select Check In from the pop-up menu. 
 
 
 
 
 
 

2. The Check In window allows you to add details about the current version of the file that you are checking in:  

 

a. Displays document name and info. 
b. Displays the document’s version number. 
c. Provide a Description of your changes. 

 

3. The following additional option is available when you 
click Show options in the Check In window:  

a. Subscribe to this file: This allows you to have a 

quicker access to the file. The file is linked to 

your Subscriptions which is located on the Tree 

pane.  

 

4. Click OK to continue. The message area will display a 

confirmation: Checkin successful. In the content pane, 

you will notice that the key icon has disappeared and 

the Version number of the file has changed.  

 
 

Checking Out a file 

When you check out a file, it will automatically check out the selected file and lock it so other users cannot modify it. It is not recommended to 

use the Check Out unless informing the eCalendar team beforehand. 

To Check Out a file: From the content pane, right-click the file and select Check Out from the pop-up menu. If you use the Check Out procedure 

and you want to now edit the file, you can do so by selecting File > Edit.

Cancel Checkout 

If you checked out a file, but did not make any changes to that file, you can choose Cancel Checkout to effectively undo the checkout. If you did 

may changes to the file, these changes will be lost. 
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Searches 

Advanced search 

After you log into Webtop, 

1. On the top of the Tree pane, click on the drop down arrow   

2. Click Advanced.   
3. An Advanced Search: General window appears and you may change the following fields: 

a. In the Object Type field, click on the drop-down list and select eCalendar Document (eCalendar _document).  
 

 
b. In the Properties field, there are three drop down lists. Follow these steps to filter by a reviewer’s role: 

i. Select Editor; =; and the Editor’s name in the drop down lists to search for files with a specific Editor:  
 
 
 
 

ii. To add another role, click on Add another property link. Another set of criteria will appear; select or. 
iii. Select Approver, = , and the Approver’s name) in drop down lists to search by Approver: 

 
 
 
 
 
 

c. Click on Search button to begin your search. 
4. The Search Results will appear in the Content pane. 

 
 
 
 
 

Saved searches 

You can save your search results to put it in the Saved Searches from the Tree pane. 

How to save your search results 

1. After completing a search, you will be in a Search Results view in the 
Content pane: 

 

2. Click Save.   
3. A Save Your Search window appears and change the following fields:  

a. Beside Name field, enter a name for your save results 
b. Beside Description field, enter a description to describe your saved search results (optional). 
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c. Make sure you uncheck Include Results and Make Public 
d. Click OK. 

How to view your saved search results and begin editing the XML document 

1. From the Tree pane, click Saved Searches. 
2. You will see the name of your saved search results in the Content 

pane. Double-click on it. 
3. You will see all documents that are assigned to your saved 

search. If you are a reviewer for a document, right-click on it and 
select Edit from the pop-up menu.  

4. Follow instructions on how to insert elements in XMAX.  
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Webtop Inbox 
Your Inbox contains tasks and notifications. Tasks are workflow items that have been assigned to you for review by the Managing Editor. 

 

Notifications are messages that an event has occurred. For example, if you are working on some documents jointly with co-workers and you 

want to be notified whenever one of those documents is edited and checked in. Webtop Inbox: 

 
1. Inbox item properties 2. Notifications  3. Tasks 

Inbox options 

Availability status 
 
This is used to inform others of your availability. Note: this feature is not used for eCalendar work. 
 
 
 
 
 
 
 
 
The default status is “available”. If you are not available, for example, going on vacation, do the following: 

1. Click on I am available link.   
2. Put a check mark on I am currently unavailable… 

 
 
 



 

 18 27 September 2017 

  

 
3. Click Edit to assign it to someone else.   
4. Find the person you want to reassign the task to and click OK.  

Get next task automatically 
 
Leave this box unchecked at all times: 
Note: this feature is not used for eCalendar work. 

Inbox items 

In the Inbox, different types of items are identified by their icon, ex.: ,  

Default Columns 

 
 
 
 

 

 Subject: This contains the document filename and type of task (icon). 

 From: Identifies who created the file by their username. 

 Date Received: The date and time the task was assigned. 

 Due Date: The date and time the task needs to be completed. This feature is not currently being used in the eCalendar. 

 Status: The status will change based on your interaction with the task. When you receive the task, the status is Dormant. The status 

changes to Acquired once you open the task (whether or not you open the actual document). 

 Repository: Indicates the location of the file. 

 Priority: Not currently being used at McGill. 
 
Note: If you want to change the default columns: 

1. Click Tools > Preferences. 
2. Click Columns tab. 
3. Scroll down to Inbox and click Edit. 
4. Choose which attributes you want to display on the inbox content 

pane. 

Notifications 

There are three different notification types: 

 Change notification: Notifies you when file(s) have been checked in: 

 
To turn on change notification: from the task view, right-click the file 
and select Turn on Change Notification from the pop-up menu. 

 Read notification: Notifies you when someone has read a file(s): 

 
To turn on read notification: from the task view, right-click the file and select Turn on Read Notification from the pop-up menu. 

 Error notification: Notifies you of an error that has occurred. 
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Task view 

From the Inbox listing, click on the task to see this view: 

 
 
Task view: 1. Tabs (only the “Info” tab is used for the eCalendar) 2. Action buttons 

Tabs 
 
The tabs are Info, Comments, and Progress. Note: only the Info tab is used for eCalendar work 

 Info tab – This tab contains instructions, the document filename, the document sender, and document properties. The bottom half of 

this tab contains the attached document, where you can take action such as view, edit, turn on notifications, and more. 

 Comments tab – This tab allows you to enter any comments about the XML document. 

To add a comment: 
1. Click Add  
2. In the Comment field, type your comment.  
3. Select one of the following radio buttons:  

a. For subsequent recipients – Sends the comment to all users performing all future tasks in the workflow.  
b. For next recipients only – Sends the comment only to the users performing the next task in the workflow.  

4. Click OK. 
Note: Enter any comments about the document before you click on any of the action buttons (Forward, Finish, Reject). You will not be 
able to add comments once the document is submitted to another user of the workflow. 

 Progress tab – This tab allows you to see the upcoming as well as past events of the workflow. 
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Action buttons 
 
There are minor differences between action buttons for Editors, Approvers, and Coordinators. 

• Editor – You will see all of these buttons in each of the tabs: 
 Previous/Next: navigates between tabs (not used for the eCalendar)
 Finish: forwards the topic to the Approver
 Close: takes you back to your Inbox

• Approver – You will see all of these buttons in each of the tabs:  
 Previous/Next: navigates between tabs (not used for the eCalendar)
 Forward: forwards the topic to the Coordinator
 Reject: sends topic back to the Editor for further revisions
 Close: takes you back to your Inbox

• Coordinator – You will see all of these buttons in each of the tabs: 
 Previous/Next: navigates between tabs (not used for the eCalendar)
 Forward: forwards the topic to the Copy Editor
 Reject: sends topic back to Editor or Approver for further revisions
 Close: brings it back to the main Inbox which is your list of tasks
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Getting Started for Individual Roles 
The following is step by step instructions for Editors, Approvers, and Coordinators in Webtop: 

Editor’s role 

After logging into Webtop: 
1. If you clicked on the task link from an email, the task view will open automatically. Otherwise, go to the Inbox from the tree pane and 

double-click on the task. 

2. In the Info tab, you will see the document filename. 
3. Edit the document: 

a.  From the bottom of the Info tab, right-click on the document and click Edit.  
  
 
  
  
  
  
 
b. Follow the instruction on how to insert elements in XMAX.  

4. Forward the task:  
a. Once you have made changes to your document and are ready to send it to the Approver, click Finish. 

  

  

b. Click OK.  

Approver’s Role 

After you have logged into Webtop: 
 

1. If you clicked on the task link from an email, the task view will open automatically. Otherwise, go to the Inbox from the Tree pane and 

double-click on the task. 

2. In the Info tab, you will see the document filename.  
3. Edit the XML document: 

a. From the bottom of the Info tab, right-click on the document and click Edit.  
  
  
  
  
  
  
b. Follow the instruction on how to insert elements in XMAX.  
c. If you feel that you need the Editor to further modify the topic, you can reject the task back to the Editor.  

From the Info tab action buttons; click Reject.  
 

 

The task will be removed from your Inbox and sends it back to the Editor.  
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Once the Editor has made the changes to the document, the task will be returned to you.  
4. Forward the task: Once you have made changes to your document and are ready to send it to the Coordinator, click Forward. 

 

 

 

Coordinator’s Role 

After you have logged into Webtop: 

 
1. If you clicked on the task link from an email, the task view will open automatically. Otherwise, go to the Inbox from the Tree pane and 

double-click on the task.  
2. In the Info tab, you will see the document filename. 
3. Edit the XML document:  

a. From the bottom of the Info tab, right-click on the document and click Edit.  
 
 
 
 
 

 

b. Follow the instruction on how to insert elements in 
XMAX.  

c. If you feel you need the editor or approver to further modify the topic, you can reject the task back to them. 
From the Info tab perform action buttons; click Reject.  

 
 
 

  Choose who you want to reject it back to. The task will be removed from your Inbox and send to the Editor or Approver. 
The task will be returned to you when the additional changes have been made. 

4. Forward the task:  
a. Once you have made changes to your document and are ready to send it to the Copy Editor, click Forward. 

  
  
 

b. You will be prompted to sign off using your McGill Password (of your McGill Username).  
c. Click OK. 
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XMAX 

XMAX is the editing software integrated with Webtop. It is used to create and modify XML (eCalendar) documents. Similar to HTML coding, 

elements are used to identify distinct types of content such a paragraphs, lists, tables, and more. The eCalendar uses a small subset of available 

elements, described below. 

Browser requirement 

XMAX only works in Internet Explorer 7, 8, 9, 10, or 11. 
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Getting started: Editors, Approvers, and Coordinators 

The following are steps on how to access XMAX and how to edit XML document for the Editor, Approver and Coordinator. 
 
Once you log into Webtop, click on a task from the Inbox Content pane. Then, the Task view will open. 
 

1. Right-click on the document filename and click Edit. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  

 
2. XMAX will open. You will see a pop up window indicating that Change Tracking is on. Click OK. 
3. Review the content of the document and make modification as needed (See section on elements) 
4. Save often (File > Save) 
5. Check In when finished working on a document for any extended period (File > Check In) 
6. The Check In window displays. Add a short Description of changes made. Click OK. XMAX will close and you will return to Webtop Inbox 
7. Repeat steps 1-6 as many times as necessary before forwarding a topic. 
8. When you are satisfied with a topic, double-click on the topic’s task in your Webtop inbox; the Task view will open 
9. Ensure that there is no key or lock icon beside the document name from the Info tab. 
10. Click the Finish or Forward button to submit it to the next reviewer. 

 
Note:  

 Make sure that you have finished making all your changes to the document. If you’ve already forwarded the topic, inform us of further 
changes by phone or email. 

 You will have another chance to review all changes when Draft 2 PDFs are sent for each reviewed topic 

 If you see the key icon beside the document filename in the Task view, you need to check in the document (right-click > Check In). 
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XMAX interface 

The application interface includes a variety of visual components to identify and manage content. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 

Figure 4: XMAX interface- Menu and toolbars on the top, the content area on the left side, the element list on the right side 

Menu and toolbars 

Menu bar – includes File, Edit, View, Insert, Tools, Table, and Help. 
 
Standard toolbar – includes icons for common tasks such as Save, Copy, Paste, etc. 
 
Formatting toolbar – includes icons for 
applying common formats such as bold, italic, 
• lists, etc. 
 
Table toolbar – includes icons for working with tables such as merging, inserting, and deleting rows or columns, etc. 
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Content area 

The content area is where you add or modify content using XML elements. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
View – there are two ways to view your document: Tag view and Normal view. These two views are located on the left-bottom of the interface. 
 
 

 Tag view is the default view. It shows the beginning and the end of each  element using icons. We recommend that you use this view to 
ensure that you don’t have any broken elements and to easily see what elements are being used as well as what elements you are 
inserting. 

 Normal view is used to see the text without the element tags. 

Element list pane 

The Element List is where you choose elements to insert into your document and appears on the right-hand side of the XMAX screen. Depending 

on the location of your cursor within the content area, the system will display the list of elements that can be used. 
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General Word Processing Functions 

XMAX has general word processing functionality, which includes but is not limited to: 

Cutting, copying, pasting text 

If you decide to cut, copy, and paste text, we recommend that you do these functions in Tag view. If you do it in the Normal view, you may break 

some elements in the document and may create invalid formatting or errors. 

Cut text – remove text and putting it in the clipboard for pasting somewhere else in the document. 
1. Select the text.  
2. Click Edit > Cut (Ctrl + x)  

Copy text – store existing text/formatting in the clipboard for reproduction somewhere else in the document. 
1. Select the text.  
2. Click Edit > Copy (Ctrl + c)  

Paste text – insert text that was most recently cut or copied to the clipboard. 
1. Insert the cursor in the correct location by clicking where you want the copied text to appear  

2. Click Edit > Paste (Ctrl + v) 

Undo text 

You can use the undo action to backtrack edits until the last save point. To Undo, click Edit > Undo (or use the keyboard shortcut, Ctrl + z) 

Save file 

You should save your file on a frequent basis, such as when you have made a major change or have finished modifying a small change. 

To Save, click File > Save (or click on the icon  from the toolbar). Note: Ctrl + s will not save your document. 

Find or find/replace 

Find – quickly search for every occurrence of specific word or phrase in your document. 

1. Click Edit > Find and Replace (or click on the icon   from the toolbar) 
2. In the Find field, enter the word or phrase that you are looking for 
3. Click Find.  

 
Find/Replace – automatically replace a word or phrase with a different one. For example, you can replace instances of “Fall 2016” with “Winter 
2017”. You can select different criteria for your replacement action. 

1. Click Edit > Find and Replace (or click on the icon   from the toolbar) 
2. In the Find field, enter the word or phrase that you want to replace  
3. In the Replace field, enter the new word or phrase 
4. Click the checkbox(es) to select replacement criteria. 

 
 
 
 
 
 

5. Click Replace, Replace, Find or Replace All.  
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Elements 

Elements are similar to HTML tags. Element tags define the type and formatting of content contained within. As in HTML tags, elements have 

opening tags (left-side) and closing tags (right side). 
 
The opening tag also allows you to collapse or expand the element. 

 When collapsed, tags look like this:  

 When expanded, tags looks like this:  

An element can also be nested within another element. For example:  

Inserting an element 

Depending on where your cursor is in the content area, the Element List pane will display the elements that you can use at that point. This 

feature helps avoid possible errors in your document markup. 

1. Position your cursor in the content area 

2. Choose an element from the Element list by clicking on it. Some commonly used elements include: 

 paragraph <p> 

 unordered list <ul> 

 ordered list <ol> 

 list item <li> 

 cross-reference <xref> (for hyperlinks) 

 table <table> 

Selecting an Element 

To select any element that is already inserted in the document, it is best to click on the element’s closing tag. 

• An element:  

• An element within other elements:  

• A group of nested elements (e.g., in this paragraph element, you are also selecting the bold and italic elements): 

 

Formatting elements 

Bold <b>, Underline <u>, Italic <i>, Citation <cite> – To insert a bold, underline, italic, or citation element, use either of the two methods below: 
Note: use of the underline element is not recommended, as it confuses between hyperlinks and regular text. 

 
1. Select some text within a paragraph, table, or list element. 

a. Choose desired element from the Element List 
b. The tags will appear around your selected text, which will now appear formatted 

or 
2. Place your cursor within a paragraph, table, or list element 

a. Choose desired element from the Element List  
b. The element tags will appear, and you can start typing your text within 

Note: The first method will not display as track changes. 
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Note <note> 

This is used for drawing attention to a section. Content within the note element will be formatted differently from the rest of the content in the 

final eCalendar. 

 
To insert a note element: 

1. Position your cursor within the body element but not within an existing paragraph, table, or list element  
2. Choose <note> from the Element List 

List elements 

Simple List – used to properly format addresses and other simple lists. 
To insert a simple list element: 

1. Position your cursor within the body element but not within an existing 
paragraph, table, or list element  

2. Choose <sl> from the Element List  
3. Start typing your text (it will automatically create a sub-list)  
4. If you want to add more sub-list items for the simple list element, position 

your cursor before the end of the </sli> tag and press enter on your keyboard. This will automatically create a new sub-list.  

 

Unordered list <ul> – the default unordered list is bulleted, though they can also be configured to be dashed. 
To create a bulleted list (default): 

1. Put your cursor at the end of a paragraph, table, or list element. 
2. Choose <ul> from the Element List. 
3. Start typing and the <li> will be created automatically. 
4. If you want to add another <li>, put the cursor before the end of </li> tag and press Enter on the keyboard. 

 
To create a dashed list: 

1. Put your cursor at the end of a paragraph, table, or list element. 
2. Choose <ul> from the Element List. 
3. Start typing and the <li> will be created automatically. 
4. If you want to add another <li>, put the cursor before the end of </li> tag and press Enter on the keyboard. 
5. Change the type attribute field to dash by:  

a. Place the cursor within one of the list’s <li> tags 
b. Click View > Attribute Inspector in the top menu 
c. Locate the type attribute and select “dash” from the drop down list 

 
 
 
 
 
 
 
 
 
 
 
 

Note: you will only see changes to the style of the list once it is published in the web eCalendar. 
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Ordered list <ol> – the default ordered list is a numbered list, though other types of list are available (see Table 1). 

 
Table 1: 

List type Displays Attribute Inspector(Type) 
 

Numbered 1. 2. 3. default  

Alphabetic a. b. c. alpha 
 

Upper alphabetic A. B. C. upperalpha 
 

Roman i. ii. iii. roman 
 

Upper roman I. II. III. upperroman 
 

 
To create a numbered list (default): 

1. Put your cursor at the end of a paragraph, table, or list element. 
2. Choose <ol> from the Element List. 
3. Start typing and the <li> will be created automatically. 
4. If you want to add another list item, put the cursor before the end of the </li> element and press Enter on the keyboard. 

 

To create other lists: 
1. Put your cursor at the end of a paragraph, table, or list element. 
2. Choose <ol> from the Element List. 
3. Start typing and the <li> will be created automatically. 
4. If you want to add another list item, put the cursor before the end of the </li> element and press Enter on the keyboard. 
5. Once you finished creating your ordered list, you have to change the type attribute field. 

a. Place the cursor within one of the list’s <li> tags 
b. Click View > Attribute Inspector from the top menu. 
c. Locate the type attribute and enter your desired type based on Table 1 above. For 

example, in this screenshot, we entered “alpha” in the type field for an alphabetic list. 

d. Turn off the Attribute Inspector by clicking on View > Attribute Inspector.  

Note: you will only see changes to the style of the list once it is published. 

Table 
 
This is used to create a table in your XML document. 
 
 
 
 
 
 
 
To insert a table:  

 
1. Click Table > Insert Table.  

 2. Select the number of rows and columns. 
3. Click OK. You should see the Table inserted in your document. 
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For other Table features, do the following: 
1. Once you insert the table, put your cursor inside a cell. 
2. Click Table from the top menu and choose any of the features from the list. 

Note: Do not insert a Table from the Element List pane; use the Insert menu. 

 

 

 

 

 

 

 

Title <title> vs long title <ltitle> 

A title and long title appear at the beginning of eCalendar documents. 
 
 

 

 

 

 

 

 

 

The title is the title that will appear at the top of the following content in the published eCalendar and PDFs. Users are able to modify the title 

and should insert a comment (Insert > Comment) explaining the requested change. 

 

The long title is an elaboration of the title, and is included for SEO purposes (to make the page easier for web search engines to find). For 

example, a topic’s title may be “Course Requirements”, while the long title may be “Course Requirements for Students in the Faculty of Law”. 

Comment 

 

 

Comment elements are for communicating internally and do not appear in the final eCalendar publication. It is used to indicate reasons for a 

change, to ask questions to others in the workflow, or to request further changes from someone else in the workflow. For example, when you 

change the title of the document, you would use a comment element to explain the change. 

 
To insert a comment element: 

1. Position your cursor within the document body 
2. Click on Insert > Comment 
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Linking and cross-references 

The cross-reference <xref> element is used within paragraph, table, or list elements. This element is also used to activate an email address and 
link it to your email client; see the email (mailto) links section for information on how to activate email addresses. 
There are two different ways to link: 
 
A. Link to an eCalendar page: This allows you to create a link to another eCalendar document. 

1. Place your cursor where you want to insert the link 
2. Click Insert > Cross Reference 
3. Browse to the file in the Webtop CMS 
4. Click the desired file and click OK 
5. Click Yes in the pop-up window. The link will be added to the document’s content. 

 

 

Note: The text that appears in the <xref> tags represents the topic’s title and cannot be changed. 

 

B. Link to a website: This allows you to create a link to a website. 
1. Place your cursor where you want to insert the link 
2. Click Insert > Web Link from the top menu 
3. Enter the full web address 

  
  
  
  
  
  
  
 

4. Click OK. The link will be added to the document’s content. 
  
 

5. Open the Attribute Inspector to make sure the format is set to “html” and the scope is set to “external”:  
a. Click text inside the <xref> tag.  
b. Click View > Attribute Inspector 
c. Scroll down to locate format and scope attributes 
d. The format attribute field should show “html”, and the scope attribute field should show external 

 
If you want to replace the web address with a text: 

1. Click and drag with your mouse to highlight the web address (make sure you don’t delete the “xref:”) 
2. Type the desired text 

  

 
  
  
  
  
Note: After you have changed the display text, you can verify the web address by hovering over the xref tags with your mouse pointer. 
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Email (mailto) links 

This allows you to activate (link) an email address in your document. 
1. Place your cursor where you want to insert the email address 
2. Click Insert > Email 
3. Enter the full email address 

  
  
  
  
  
  
  

4. Click OK. The linked email address will be added to the document’s content. 
  
 
 

5. Open the Attribute Inspector to make sure the format is set to “html” and the scope is set to “external”:  
a. Click text inside the <xref> tag. 
b. Click View > Attribute Inspector 
c. Scroll down to locate format and scope attributes 
d. The format attribute field should show “html”, and the scope attribute field should show external 

 
If you want to replace the email address with text: 

1. Click and drag with your mouse to highlight the email address (make sure you don’t delete the “xref:”) 
2. Type the desired text 

  
 

Advanced Elements 

Subtopic 

A subtopic is created using the <topic> element tags and used when content is closely related to, and should be linked to, its parent topic. A 

subtopic should be created only when its content and flow will be clearest as a subtopic of another standalone topic, as opposed to a subsection 

of that other topic or as its own standalone topic.  

Note: Most users do not have access to create subtopics. Please leave a comment (Insert > Comment) for Enrolment Services to request a 

subtopic. 
 
 
 
 
How to create a subtopic: 

1. Place your cursor before the closing </topic> at the end of a document’s content 
2. Double-click on topic in the element list 
3. Place your cursor between the <title> tags and enter your desired subtopic title 
4. Place your cursor after the </title> tag and double-click on ltitle in the element list and enter your desired long title 
5. Place your cursor between the <body> tags and enter your desired subtopic text 
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Superscript 

The superscript <sup> element is useful when displaying indicators (e.g., numbers, symbols) that appear smaller and above the baseline. For 

example, 3rd Floor (the “rd” would appear between <sup> tags). 

Subscript 

The subscript <sub> is useful when displaying indicators (e.g., numbers, symbols) that appear smaller and below the baseline. For example, in 

water’s chemical formula H2O, the “2” would appear between <sub> tags. 

Tips for Inserting Elements 

The following are tips to keep in mind when you insert an element: 
• Use the elements listed in the inserting an element and advanced elements sections.  
• Don’t create table, note, and list elements within a paragraph element; it is best to create these elements by themselves. 

• You can insert accented characters using the keyboard shortcuts (e.g., alt + 130) or using the Character Map (PC only; Start menu > All 

Programs > System Tools > Character Map).  

• All special characters work in XMAX; it will transform them in the special encoding code if necessary. N 

• Use the “Enter” button carefully; hitting the ‘Enter’ button sometimes inserts a new element. 
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Track Changes 
Track changes allows you to keep track of any modifications—inserted, deleted, moved, or modified text– when made to content in the 

document. 

 
When editing a document, track changes is enabled automatically. Click OK to start editing. 
 
Note: if a change ever fails to display as a tracked change, please leave a comment in the document 
(Insert > Comment) indicating the change. 

• Added text:   

• Deleted text:  

Viewing track changes 

If track changes appear in your document, it means that another user has already modified the document. Hover over the changed text to view 

the name of the user who made the modification, as well as the date the modification was made, in a popup. 

 

 

 

 

How to use Track Changes 

You can jump to tracked changes in a document; in the top menu, click Tools > Next Change or Previous Change: 

 

Next Change – to view the next change, click Tools > Next Change. This will bring your cursor to the next modified 
content in the document. 
 
Previous Change – to view the previous change, click Tools > Previous Change. This will bring your cursor to the 
previous modified content in the document. 
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Spell Checker 
As with all documents, it is good practice to perform a spell check on it before saving and checking it in. 
Note: this functionality is not used for the eCalendar 

How to use the Spell Checker 

To invoke the Spell Checker: 
1.  Click Tools > Spellchecker 

 
 
 
 
 
 
 
 
 
 
 

2.  The Writing Tools pop-up box will appear with the spelling error. 
 
 
 
 
 
 
 
 
 
 

Note: Use this feature the same as you would use in any other Spell Checker tool such as in Word. 
3. After the system has verified all spelling errors in your document, click Yes to exit the Spell Checker. 

 
 
 
 
 
 
 
 
 
 

Set the Language 

You can set your preferred language for the Spell Checker tool. 
 
To set the language: 

1. After opening your document, click Tools > Spellchecker 
2. From the Writing tools pop-up, click Options > Language 
3. Select the desired language from the Select Language window  
4. Click the Save as default Writing Tools language in the check box  
5. Click OK.  
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Validation 
Documents have to adhere to a set of rules which ensure that the document follows a required structure for successful publication. The Element 

List pane is one of the ways the system validates the XML language. Using the Element List pane is preferred since only the elements that can be 

inserted in the current location are listed. This will prevent errors. 

 

You can also use the Validation feature to thoroughly check your document, which will report any errors that are found. Normally, two types of 

validation errors may occur: 

1. Missing content 
2. Content that is tagged incorrectly 

You can perform a validation check at any time to find errors in either a selection of your document or the entire document. 

 

1. To validate your document:  
a.  Click Tools > Validate Document.  

 
 
 
 
 
 
 
 
 

 

2. To validate a selection of your document:  
a. Select the section that you would like to validate.  
b. Click Tools > Validate Selection  

  
  
  
  
  
  
  
  

Understanding the Validation Errors 

Errors – if your document has validation errors, a Validation Log containing a list of error 
messages displays. This will give you further information on the errors, allowing you to find 
and correct them. 

 
Note: you can go to the location of an error by double-clicking the error message. 
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Best Practices 
When working with documents for the eCalendar, we recommend the following best practices: 
 

Do’s Don’ts 

 Save often and after any major changes 

 Use undo feature when you make a mistake 
 Check In when you are finished working on your topic 
 Insert comments in the content whenever necessary (Insert > 

Comment) 

 Use only elements mentioned in the inserting an element 
section 

 Don’t modify Prolog information 
 Don’t use the Internet Explorer menu 
 Do not use the Internet Explorer back/forward button 

 

Support 
 Questions about the eCalendar process, Webtop, and XMAX:

o Contact ecalendarsupport.es@mcgill.ca 

 Login and technical issues: 
o Contact IT Customer Services at 514-398-3398 or itsupport@mcgill.ca 

mailto:ecalendarsupport.es@mcgill.ca
mailto:itsupport@mcgill.ca

